Solution d'analyse de données

Analyse factorielle des correspondances à partir de données brutes avec représentation 3D

20/10/2017

Ce tutoriel vous aidera à configurer et interpréter une Analyse Factorielle des Correspondances (AFC) à partir de données brutes dans Excel avec le logiciel XLSTAT.
Ce guide vous permettra de choisir une méthode d'analyse multivariée appropriée en fonction de votre question et vos données

Jeu de données pour réaliser une analyse factorielle des correspondances à partir d’un tableau de données brutes

Un classeur Excel comprenant à la fois les données utilisées dans cet exemple et les résultats obtenus peut être téléchargé en cliquant sur le bouton ci-dessous :
Télécharger les données

Les données correspondent à une liste de joueurs de football étrangers et leurs nationalités. Nous souhaitons étudier la distribution des joueurs étrangers dans les clubs anglais.

Paramétrer une analyse factorielle des correspondances à partir d’un tableau de données brutes

Pour activer l’analyse, démarrez XLSTAT, puis sélectionnez la commande Analyse des données/ Analyse factorielle des correspondances (AFC) ou cliquez sur le bouton correspondant.

XLSTAT Menu Analyse des Données, AFC

Une fois que vous avez sélectionné la fonction, la boîte de dialogue apparaît. 

Pour le format, cliquez sur : Tableau Observations / Variables
Dans le champ Observations/Variables, sélectionnez les colonnes Clubs et régions du tableau Excel.

Les noms des colonnes étant sélectionnés, cliquez sur Libellés des variables.

Cliquez sur Feuille pour le format de sortie des résultats.

XLSTAT AFC pour Excel, boîte de dialogue, onglet Général

 Dans l’onglet Options, cliquez sur le Test d’indépendance et laissez le niveau de signification à 5.

XLSTAT Analyse Factorielle des Correspondances pour Excel, boîte de dialogue, onglet Options

 Dans l’onglet Sortie, sélectionnez les éléments suivants :

  • Tableau de contingence
  • Valeurs Propres
  • Coordonnées principales
  • Coordonnées standard
  • Contributions
  • Cosinus carrés

XLSTAT AFC pour Excel, boîte de dialogue, onglet Sorties

Sur l’onglet Graphiques, Sélectionnez les options suivantes :

  • Graphiques Symétriques
  • Graphiques Asymétriques
  • Etiquettes

XLSTAT AFC pour Excel, boîte de dialogue, onglet Graphiques

Cliquez sur OK.

Ce modèle nécessite plus de 2 facteurs. Cliquez d’abord sur Sélectionner pour choisir  le graphique F1-F2. Changez l’abscisse en F2. Cela change l’ordonnée en F3. Cliquez de nouveau sur Sélectionner. De cette façon, vous aurez 2 graphiques : F1-F2 et F2-F3. Cliquez sur Terminer.

XLSTAT AFC pour Excel, choix des axes

Interpréter les résultats d’une analyse factorielle des correspondances

Les premiers résultats sont la table de contingence et le test d’indépendance entre les lignes et les colonnes.

La p-value de 0.008 est inférieur à 5%, de ce fait l’hypothèse de nullité doit être rejetée. Cela signifie que la distribution des nationalités dans les clubs anglais n’est pas un hasard.

ca2_6.png

Vient ensuite le graphique symétrique. Dans ce premier graphique vous pouvez voir que les clubs tels que Aston Villa et Stoke City ont plus de joueurs d’Amérique du Nord que les autres équipes. De la même façon, Burney a beaucoup de joueurs Européens.

ca2_7.png

Créer un graphique 3DPlot pour l’analyse des résultats

Nous allons maintenant faire un graphique en 3 Dimensions pour avoir une meilleure représentation des points.

Nous faisons d’abord un tableau contenant à la fois les 3 coordonnées principales pour les clubs et les données géographiques et la somme des cosinus pour ses 3 facteurs.

La somme au carré des cosinus pour les 3 facteurs, obtenue à partir du tableau des cosinus au carré, nous donne une idée de comment est représenté l’échantillon dans l’espace en 3D.

Rajoutez une dernière colonne pour avoir l’information sur les lignes / Colonnes. Les lignes sont les clubs et les colonnes les régions. Créer une variable de catégorie avec R et C pour décrire chaque échantillon.

ca2_7b.png

Sélectionnez le tableau en entier et allez sur le menu Visualiser les données, sélectionnez l’option XLSTAT-3DPlot.

 Choisissez le format Tableau pour vos données.

ca2_8.png

Il est nécessaire de spécifier les axes. Pour ce faire, cliquez droit et sélectionnez la variable à utiliser. Pour les 3 axes nous utilisons : F1, F2 sur l’axe horizontale et F3 sur l’axe verticale.

Il est aussi nécessaire de définir la taille des axes afin d’obtenir un graphique orthonormé. Vous pouvez par exemple utiliser pour tous les axes : -des limites de 1.5 et 1.5.

ca2_9.png

Pour la couleur et la taille du point vous pouvez utiliser la somme des cosinus. Allez sur l’onglet Objet et modifiez les données dans la section couleur et taille.

ca2_10.png

Pour finir, nous rajoutons les étiquettes dans l’onglet Annotations en sélectionnant “ Colonne 1 “.

ca2_11.png

Voici votre représentation en 3 Dimensions 

ca2_12.png

1c26995d494fb3061dd0ae8571ffc0a4@xlstat.desk-mail.com
https://cdn.desk.com/
false
desk
Chargement
il y a quelques secondes
il y a une minute
il y a quelques minutes
il y a une heure
il y a quelques heures
il y a un jour
il y a quelques jours
à propos de
false
Caractères non valides trouvés
/customer/portal/articles/autocomplete
9283